Antispam Bee 2.11.2 veröffentlicht


Deprecated: mb_convert_encoding(): Handling HTML entities via mbstring is deprecated; use htmlspecialchars, htmlentities, or mb_encode_numericentity/mb_decode_numericentity instead in /sites/login.pluginkollektiv.org/files/wp-content/plugins/wp-anchor-header/wp-anchor-header.php on line 69

Während wir im Hintergrund am nächsten großen Update von Antispam Bee arbeiten, haben wir heute Version 2.11.2 veröffentlicht.

Kompatibilität mit PHP 8.1 und WordPress 6.1

Wie immer haben wir ein genaues Auge darauf, dass Antispam Bee mit der neuesten WordPress-Version kompatibel ist. Für WP 6.1 mussten wir dieses Mal keine Änderungen vornehmen. Stattdessen haben wir uns einem kleinen Problem mit PHP 8.1 gewidmet. Wer Antispam Bee unter PHP 8.1 installiert hatte, aber noch keinen Spam erhalten hat (herzlich Glückwunsch!), wurde unter Umständen mit einer hässlichen PHP-Warnung belästigt. Das passiert ab sofort nicht mehr.

Diverse kleine Probleme mit Übersetzungen

Antispam Bee wird von vielen, vielen Freiwilligen in inzwischen 27 Sprachen übersetzt. ♥️ Auch deshalb haben wir einen genaueren Blick auf den Code rund um unsere Übersetzungen geworfen und einige kleine Fehler behoben.

Ab sofort können Spam-Gründe, die auf der Kommentar-Seite angezeigt werden, auch übersetzt werden. Außerdem haben wir einige überflüssige Übersetzungen entfernt und etwas Code angepasst, der Übersetzungsdateien manchmal ganz frech doppelt geladen hat.

Das war es schon. Jetzt konzentrieren wir uns weiter auf Antispam Bee 3.0 und melden uns hoffentlich schon bald mit einer Testversion zurück.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert